can’t load mod_rewrite in ubuntu 10.04

run sudo a2enmod rewrite then restart apache

Change / Reset the MySQL root password on Ubuntu Linux

Tested on
– Ubuntu Linux 7.10 Gutsy Gibbon and MySQL 5.0.45. (2007-10-21)
– Ubuntu Linux 6.06 Dapper Drake and MySQL 4.1.15.

Set / change / reset the MySQL root password on Ubuntu Linux. Enter the following lines in your terminal.

    1. Stop the MySQL Server.
      sudo /etc/init.d/mysql stop

 

    1. Start the mysqld configuration.
      sudo mysqld --skip-grant-tables &

 

    1. Login to MySQL as root.
      mysql -u root mysql

 

    1. Replace YOURNEWPASSWORD with your new password!
      UPDATE user SET Password=PASSWORD('YOURNEWPASSWORD') WHERE User='root'; FLUSH PRIVILEGES; exit;

Note: This method is not regarded as the securest way of resetting the password. However it works.

Prioritas Trafic Game IIX – by ForumMikrotik

Ok, langsung aja…

krn dsni hanya membahas game online IIX maka langkah pertama kita buat address-list yang berisi list IP address IIX. Cara nya, buka New Terminal di winbox dan ketikan perintah bekikut:

>_

/tool fetch address=ixp.mikrotik.co.id src-path=/download/nice.rsc mode=http;

Kemudian di-import dengan perintah:

>_

import nice.rsc

Setelah address-list nice siap, lanjutkan dengan konfigurasi MANGLE…
Untuk warnet dengan 1 ISP, kita hanya perlu membedakan antara traffic game & browsing dari prioritas nya di Queue… yang perlu dilakukan antara lain sbb;

langkah pertama, Tangkap traffic game online berdasarkan port nya masing2 dengan dengan mark-connection…
(daftar port game yang saya gunakan diambil dari punya bro dingo disini)

>_

/ip firewall mangle
add action=mark-connection chain=prerouting comment=”Ayo Dance” disabled=no dst-address-list=nice dst-port=18900-18910 \
new-connection-mark=game-online-indonesia passthrough=yes protocol=tcp
add action=mark-connection chain=prerouting comment=”Seal Online” disabled=no dst-address-list=nice dst-port=1818 \
new-connection-mark=game-online-indonesia passthrough=yes protocol=tcp
add action=mark-connection chain=prerouting comment=”Lineage 2″ disabled=no dst-address-list=nice dst-port=7777 \
new-connection-mark=game-online-indonesia passthrough=yes protocol=tcp
add action=mark-connection chain=prerouting comment=IDS disabled=no dst-address-list=nice dst-port=2001 new-connection-mark=\
game-online-indonesia passthrough=yes protocol=tcp
add action=mark-connection chain=prerouting comment=PB-UDP disabled=no dst-address-list=nice dst-port=40000-40010 \
new-connection-mark=game-online-indonesia passthrough=yes protocol=udp
add action=mark-connection chain=prerouting comment=PB-TCP disabled=no dst-address-list=nice dst-port=39000-40000 \
new-connection-mark=game-online-indonesia passthrough=yes protocol=tcp
add action=mark-connection chain=prerouting comment=”Ghost Online” disabled=no dst-address-list=nice dst-port=19101 \
new-connection-mark=game-online-indonesia passthrough=yes protocol=tcp
add action=mark-connection chain=prerouting comment=RF-Elven disabled=no dst-address-list=nice dst-port=27780 \
new-connection-mark=game-online-indonesia passthrough=yes protocol=tcp
add action=mark-connection chain=prerouting comment=”Perfect World” disabled=no dst-address-list=nice dst-port=29000 \
new-connection-mark=game-online-indonesia passthrough=yes protocol=tcp
add action=mark-connection chain=prerouting comment=Rohan disabled=no dst-address-list=nice dst-port=22100 new-connection-mark=\
game-online-indonesia passthrough=yes protocol=tcp
add action=mark-connection chain=prerouting comment=”Zeus RO” disabled=no dst-address-list=nice dst-port=5121 \
new-connection-mark=game-online-indonesia passthrough=yes protocol=tcp
add action=mark-connection chain=prerouting comment=DOTA disabled=no dst-address-list=nice dst-port=6000-6125 \
new-connection-mark=game-online-indonesia passthrough=yes protocol=tcp
add action=mark-connection chain=prerouting comment=”Crazy Kart” disabled=no dst-address-list=nice dst-port=9600-9602 \
new-connection-mark=game-online-indonesia passthrough=yes protocol=tcp
add action=mark-connection chain=prerouting comment=”WOW AMPM” disabled=no dst-address-list=nice dst-port=8085 \
new-connection-mark=game-online-indonesia passthrough=yes protocol=tcp
add action=mark-connection chain=prerouting comment=”Drift City” disabled=no dst-address-list=nice dst-port=11011-11041 \
new-connection-mark=game-online-indonesia passthrough=yes protocol=tcp
add action=mark-connection chain=prerouting comment=GetAmped disabled=no dst-address-list=nice dst-port=13413 \
new-connection-mark=game-online-indonesia passthrough=yes protocol=tcp
add action=mark-connection chain=prerouting comment=Yullgang disabled=no dst-address-list=nice dst-port=19000 \
new-connection-mark=game-online-indonesia passthrough=yes protocol=tcp
add action=mark-connection chain=prerouting comment=”RAN Online” disabled=no dst-address-list=nice dst-port=5105 \
new-connection-mark=game-online-indonesia passthrough=yes protocol=tcp
add action=mark-connection chain=prerouting comment=”Cross Fire TCP” disabled=no dst-address-list=nice dst-port=\
10009,13008,16666,28012 new-connection-mark=game-online-indonesia passthrough=yes protocol=tcp
add action=mark-connection chain=prerouting comment=”Cross Fire UDP” disabled=no dst-address-list=nice dst-port=\
12020-12080,13000-13080 new-connection-mark=game-online-indonesia passthrough=yes protocol=udp
add action=mark-connection chain=prerouting comment=”War Rock” disabled=no dst-address-list=nice dst-port=5340-5352 \
new-connection-mark=game-online-indonesia passthrough=yes protocol=tcp
add action=mark-connection chain=prerouting comment=”Fast Black” disabled=no dst-address-list=nice dst-port=6000-6001 \
new-connection-mark=game-online-indonesia passthrough=yes protocol=tcp
add action=mark-connection chain=prerouting comment=”Rose Online” disabled=no dst-address-list=nice dst-port=29200 \
new-connection-mark=game-online-indonesia passthrough=yes protocol=tcp
add action=mark-connection chain=prerouting comment=”Crazy Kart 2″ disabled=no dst-address-list=nice dst-port=9600 \
new-connection-mark=game-online-indonesia passthrough=yes protocol=tcp
add action=mark-connection chain=prerouting comment=”Return of Warrior” disabled=no dst-address-list=nice dst-port=10402 \
new-connection-mark=game-online-indonesia passthrough=yes protocol=tcp
add action=mark-connection chain=prerouting comment=”Luna Online” disabled=no dst-address-list=nice dst-port=15000-15002 \
new-connection-mark=game-online-indonesia passthrough=yes protocol=tcp
add action=mark-connection chain=prerouting comment=”Runes of Magic” disabled=no dst-address-list=nice dst-port=16400-16502 \
new-connection-mark=game-online-indonesia passthrough=yes protocol=tcp
add action=mark-connection chain=prerouting comment=”Fresh Ragnarok PS” disabled=no dst-address-list=nice dst-port=5171 \
new-connection-mark=game-online-indonesia passthrough=yes protocol=tcp
add action=mark-connection chain=prerouting comment=”Tantra Online” disabled=no dst-address-list=nice dst-port=3010 \
new-connection-mark=game-online-indonesia passthrough=yes protocol=tcp
add action=mark-connection chain=prerouting comment=Atlantica disabled=no dst-address-list=nice dst-port=4300 \
new-connection-mark=game-online-indonesia passthrough=yes protocol=tcp
add action=mark-connection chain=prerouting comment=”ECO Online” disabled=no dst-address-list=nice dst-port=12011,12110 \
new-connection-mark=game-online-indonesia passthrough=yes protocol=tcp
add action=mark-connection chain=prerouting comment=”Cabal Indonesia” disabled=no dst-address-list=nice dst-port=15000-15002 \
new-connection-mark=game-online-indonesia passthrough=yes protocol=tcp
add action=mark-connection chain=prerouting comment=Avalon disabled=no dst-address-list=nice dst-port=9376-9377 \
new-connection-mark=game-online-indonesia passthrough=yes protocol=tcp
add action=mark-connection chain=prerouting comment=”X-Shot UDP” disabled=no dst-address-list=nice dst-port=7777-7977,30000 \
new-connection-mark=game-online-indonesia passthrough=yes protocol=udp
add action=mark-connection chain=prerouting comment=”3 Kingdoms” disabled=no dst-address-list=nice dst-port=15000-15002 \
new-connection-mark=game-online-indonesia passthrough=yes protocol=udp
add action=mark-connection chain=prerouting comment=”Grand Chase TCP” disabled=no dst-address-list=nice dst-port=\
9300,9400,9700 new-connection-mark=game-online-indonesia passthrough=yes protocol=tcp
add action=mark-connection chain=prerouting comment=”Grand Chase UDP” disabled=no dst-address-list=nice dst-port=9401,9600 \
new-connection-mark=game-online-indonesia passthrough=yes protocol=udp
add action=mark-connection chain=prerouting comment=MAKO disabled=no dst-address-list=nice dst-port=21000-21020 \
new-connection-mark=game-online-indonesia passthrough=yes protocol=tcp

Kemudian bikin mark-packet agar dapat ditangkap di Queue berdasarkan mark-connection yang dibuat tadi (dalam contoh disini nama mark-connection nya adalah “game-online-indonesia”)

>_

/ip firewall mangle add chain=prerouting connection-mark=game-online-indonesia action=mark-packet new-packet-mark=Game

trus bikin satu lagi mark-packet untuk trafic diluar traffic game yang sudah dibuat tadi:

>_

/ip firewall mangle add chain=prerouting connection-mark=!game-online-indonesia action=mark-packet new-packet-mark=Browsing

Terakhir, tinggal buat 2 queue berdasarkan 2 packet-mark tadi yaitu Game dan Browsing… berikut contoh untuk warnet yang punya bandwidth 512kbps downstream/upstream…

>_

/queue simple
add burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s comment=”” direction=both disabled=no dst-address=0.0.0.0/0 \
interface=all max-limit=512k/512k name=Game packet-marks=”Game” parent=none priority=1 \
queue=default-small/default-small total-queue=default-small
add burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s comment=”” direction=both disabled=no dst-address=0.0.0.0/0 \
interface=all max-limit=512k/512k name=Browsing packet-marks=”Browsing” parent=none priority=8 \
queue=default-small/default-small total-queue=default-small

Dengan begitu antara traffic game dan yang bukan game udah terpisahkan namun belum ada pembagian bandwidth per client nya… untuk itu kita tinggal membuat queue child dengan parent “Browsing” kemudian masukan target-address sesuai dengan IP address tiap2 PC-client nya tanpa packet-mark…
Contoh:

>_

/queue simple add burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s comment=”” direction=both disabled=no dst-address=0.0.0.0/0 \
interface=all limit-at=32k/64k max-limit=64k/128k name=PC-2 parent=Browsing priority=4 queue=default-small/default-small target-addresses=10.0.0.2/32 total-queue=default-small

Perlu diingat dalam memasukan angka limit-at, akumulasi dari keseluruhan queue child tidak boleh melebihi total max-limit dari queue parent nya…

Berikutnya, untuk warnet yang punya multi backbone, maka akan kita pisahkan dengan Static Routing…

Biar halaman ini gak kepanjangan jadi gak usah saya tulis lagi satu2 semua mangle di atas yach…
krn dari mangle dengan action mark-connection di atas kita hanya perlu merubah nya menjadi mark-routing…
contoh nya 1 aja yach

>_

/ip firewall mangle
add action=mark-routing chain=prerouting comment=”Ayo Dance” disabled=no dst-address-list=nice dst-port=18900-18910 \
new-routing-mark=game-online-indonesia passthrough=yes protocol=tcp

tinggal ulangi semua yang di atas tadi dengan mengganti mark-connection ke mark-routing dan new-connection-mark ganti ke new-routing-mark…

Terakhir, bikin Routing nya:

>_


/ip route add gateway [ip address gateway ISP-A]
/ip route add gateway [ip address gateway ISP-B] routing-mark=game-online-indonesia

Koneksi SSH pada Cisco Switch

waduhh… ini pengalaman pertama si switch disimpen diluar datacenter.. dan harus bisa di remote ssh, padahal biasanya saya ngeconfig langsung menggunakan terminal..  sempat baca referensi2 dan tutorial cisco.. semua menjelaskan bagaimana membuat cisco bisa diremote dgn ssh.. tapi saya stuck ketika saya remote cisco dengan putty disana minta userid dan pass.. saya suda daftarkan username saya tetep ga bisa masuk ternyata ada config yg terlwat..

Cek ssh dah enable blom ?

Router# show ip ssh

%SSH has not been enabled

klo blom masuk config dan buat hostname

Router(config)# hostname pd1hukum

dan buat domain

pd1hukum(config)# ip domain-name fh.unpad.ac.id

Generate a RSA Key Pair

pd1hukum(config)# crypto key generate rsa

klo mo menggunakan ssh versi 2 usahakan modulusnya menggunakan diatas 786bit

Set SSH  ke version 2

pd1hukum(config)# ip ssh version 2

Set SSH  ke version 1

pd1hukum(config)# ip ssh version 1

set SSH version 1 dan 2

pd1hukum(config)# no ip ssh version

Set the SSH  timeout dan percobaan koneksi

pd1hukum(config)# ip ssh time-out 120

pd1hukum(config)# ip ssh authetication-retries 3

pd1hukum(config)# username arry password c1sco

Set VTY .

pd1hukum(config)# line vty 0 4

pd1hukum(config-line)# transport input ssh

pd1hukum(config-line)# login local

pd1hukum(config-line)# privileges level 0

 

sekian dan terima kasih

 

Load Balance menggunakan Metode PCC

Load balance pada mikrotik adalah teknik untuk mendistribusikan beban trafik pada dua atau lebih jalur koneksi secara seimbang, agar trafik dapat berjalan optimal, memaksimalkan throughput, memperkecil waktu tanggap dan menghindari overload pada salah satu jalur koneksi.

Selama ini banyak dari kita yang beranggapan salah, bahwa dengan menggunakan loadbalance dua jalur koneksi , maka besar bandwidth yang akan kita dapatkan menjadi dua kali lipat dari bandwidth sebelum menggunakan loadbalance (akumulasi dari kedua bandwidth tersebut). Hal ini perlu kita perjelas dahulu, bahwa loadbalance tidak akan menambah besar bandwidth yang kita peroleh, tetapi hanya bertugas untuk membagi trafik dari kedua bandwidth tersebut agar dapat terpakai secara seimbang.

Dengan artikel ini, kita akan membuktikan bahwa dalam penggunaan loadbalancing tidak seperti rumus matematika 512 + 256 = 768, akan tetapi 512 + 256 = 512 + 256, atau 512 + 256 = 256 + 256 + 256.

Pada artikel ini kami menggunakan RB433UAH dengan kondisi sebagai berikut :
1.    Ether1 dan Ether2 terhubung pada ISP yang berbeda dengan besar bandwdith yang berbeda. ISP1 sebesar 512kbps dan ISP2 sebesar 256kbps.
2.    Kita akan menggunakan web-proxy internal dan menggunakan openDNS.
3.    Mikrotik RouterOS anda menggunakan versi 4.5  karena fitur PCC mulai dikenal pada versi 3.24.

Jika pada kondisi diatas berbeda dengan kondisi jaringan ditempat anda, maka konfigurasi yang akan kita jabarkan disini harus anda sesuaikan dengan konfigurasi untuk jaringan ditempat anda.

Konfigurasi Dasar

Berikut ini adalah Topologi Jaringan dan IP address yang akan kita gunakan

 

/ip address
add address=192.168.101.2/30 interface=ether1
add address=192.168.102.2/30 interface=ether2
add address=10.10.10.1/24 interface=wlan2
/ip dns
set allow-remote-requests=yes primary-dns=208.67.222.222 secondary-dns=208.67.220.220

Untuk koneksi client, kita menggunakan koneksi wireless pada wlan2 dengan range IP client 10.10.10.2 s/d 10.10.10.254 netmask 255.255.255.0, dimana IP 10.10.10.1 yang dipasangkan pada wlan2 berfungsi sebagai gateway dan dns server dari client. Jika anda menggunakan DNS dari salah satu isp anda, maka akan ada tambahan mangle yang akan kami berikan tanda tebal

Setelah pengkonfigurasian IP dan DNS sudah benar, kita harus memasangkan default route ke masing-masing IP gateway ISP kita agar router meneruskan semua trafik yang tidak terhubung padanya ke gateway tersebut. Disini kita menggunakan fitur check-gateway berguna jika salah satu gateway kita putus, maka koneksi akan dibelokkan ke gateway lainnya.

/ip route
add dst-address=0.0.0.0/0 gateway=192.168.101.1 distance=1 check-gateway=ping
add dst-address=0.0.0.0/0 gateway=192.168.102.1 distance=2 check-gateway=ping

Untuk pengaturan Access Point sehingga PC client dapat terhubung dengan wireless kita, kita menggunakan perintah

/interface wireless
set wlan2 mode=ap-bridge band=2.4ghz-b/g ssid=Mikrotik disabled=no

Agar pc client dapat melakukan koneksi ke internet, kita juga harus merubah IP privat client ke IP publik yang ada di interface publik kita yaitu ether1 dan ether2.

/ip firewall nat
add action=masquerade chain=srcnat out-interface=ether1
add action=masquerade chain=srcnat out-interface=ether2

Sampai langkah ini, router dan pc client sudah dapat melakukan koneksi internet. Lakukan ping baik dari router ataupun pc client ke internet. Jika belum berhasil, cek sekali lagi konfigurasi anda.
Webproxy Internal

Pada routerboard tertentu, seperti RB450G, RB433AH, RB433UAH, RB800 dan RB1100 mempunyai expansion slot (USB, MicroSD, CompactFlash) untuk storage tambahan. Pada contoh berikut, kita akan menggunakan usb flashdisk yang dipasangkan pada slot USB. Untuk pertama kali pemasangan, storage tambahan ini akan terbaca statusnya invalid di /system store. Agar dapat digunakan sebagai media penyimpan cache, maka storage harus diformat dahulu dan diaktifkan Nantinya kita tinggal mengaktifkan webproxy dan set cache-on-disk=yes untuk menggunakan media storage kita. Jangan lupa untuk membelokkan trafik HTTP (tcp port 80) kedalam webproxy kita.

/store disk format-drive usb1
/store
add disk=usb1 name=cache-usb type=web-proxy
activate cache-usb

/ip proxy
set cache-on-disk=yes enabled=yes max-cache-size=200000KiB port=8080

/ip firewall nat
add chain=dstnat protocol=tcp dst-port=80 in-interface=wlan2 action=redirect to-ports=8080

Pengaturan Mangle

Pada loadbalancing kali ini kita akan menggunakan fitur yang disebut PCC (Per Connection Classifier). Dengan PCC kita bisa mengelompokan trafik koneksi yang melalui atau keluar masuk router menjadi beberapa kelompok. Pengelompokan ini bisa dibedakan berdasarkan src-address, dst-address, src-port dan atau dst-port. Router akan mengingat-ingat jalur gateway yang dilewati diawal trafik koneksi, sehingga pada paket-paket selanjutnya yang masih berkaitan dengan koneksi awalnya akan dilewatkan  pada jalur gateway yang sama juga. Kelebihan dari PCC ini yang menjawab banyaknya keluhan sering putusnya koneksi pada teknik loadbalancing lainnya sebelum adanya PCC karena perpindahan gateway..
Sebelum membuat mangle loadbalance, untuk mencegah terjadinya loop routing pada trafik, maka semua trafik client yang menuju network yang terhubung langsung dengan router, harus kita bypass dari loadbalancing. Kita bisa membuat daftar IP yang masih dalam satu network router dan  memasang mangle pertama kali sebagai berikut

/ip firewall address-list
add address=192.168.101.0/30 list=lokal
add address=192.168.102.0/30 list=lokal
add address=10.10.10.0/24 list=lokal

/ip firewall mangle
add action=accept chain=prerouting dst-address-list=lokal in-interface=wlan2 comment=”trafik lokal”
add action=accept chain=output dst-address-list=lokal

Pada kasus tertentu, trafik pertama bisa berasal dari Internet, seperti penggunaan remote winbox atau telnet dari internet dan sebagainya, oleh karena itu kita juga memerlukan mark-connection untuk menandai trafik tersebut agar trafik baliknya juga bisa melewati interface dimana trafik itu masuk

/ip firewall mangle
add action=mark-connection chain=prerouting connection-mark=no-mark in-interface=ether1 new-connection-mark=con-from-isp1 passthrough=yes comment=”trafik dari isp1”
add action=mark-connection chain=prerouting connection-mark=no-mark in-interface=ether2 new-connection-mark=con-from-isp2 passthrough=yes comment=”trafik dari isp2”

Umumnya, sebuah ISP akan membatasi akses DNS servernya dari IP yang hanya dikenalnya, jadi jika anda menggunakan DNS dari salah satu ISP anda, anda harus menambahkan mangle agar trafik DNS tersebut melalui gateway ISP yang bersangkutan bukan melalui gateway ISP lainnya. Disini kami berikan mangle DNS ISP1 yang melalui gateway ISP1. Jika anda menggunakan publik DNS independent, seperti opendns, anda tidak memerlukan mangle dibawah ini.

/ip firewall mangle
add action=mark-connection chain=output comment=dns dst-address=202.65.112.21 dst-port=53 new-connection-mark=dns passthrough=yes protocol=tcp comment=”trafik DNS citra.net.id”
add action=mark-connection chain=output dst-address=202.65.112.21 dst-port=53 new-connection-mark=dns passthrough=yes protocol=udp
add action=mark-routing chain=output connection-mark=dns new-routing-mark=route-to-isp1 passthrough=no

Karena kita menggunakan webproxy pada router, maka trafik yang perlu kita loadbalance ada 2 jenis. Yang pertama adalah trafik dari client menuju internet (non HTTP), dan trafik dari webproxy menuju internet. Agar lebih terstruktur dan mudah dalam pembacaannya, kita akan menggunakan custom-chain sebagai berikut :

/ip firewall mangle
add action=jump chain=prerouting comment=”lompat ke client-lb” connection-mark=no-mark in-interface=wlan2 jump-target=client-lb
add action=jump chain=output comment=”lompat ke lb-proxy” connection-mark=no-mark out-interface=!wlan2 jump-target=lb-proxy

Pada mangle diatas, untuk trafik loadbalance client pastikan parameter in-interface adalah interface yang terhubung dengan client, dan untuk trafik loadbalance webproxy, kita menggunakan chain output dengan parameter out-interface yang bukan terhubung ke interface client. Setelah custom chain untuk loadbalancing dibuat, kita bisa membuat mangle di custom chain tersebut sebagai berikut

/ip firewall mangle
add action=mark-connection chain=client-lb dst-address-type=!local new-connection-mark=to-isp1 passthrough=yes per-connection-classifier=both-addresses:3/0 comment=”awal loadbalancing klien”
add action=mark-connection chain=client-lb dst-address-type=!local new-connection-mark=to-isp1 passthrough=yes per-connection-classifier=both-addresses:3/1
add action=mark-connection chain=client-lb dst-address-type=!local new-connection-mark=to-isp2 passthrough=yes per-connection-classifier=both-addresses:3/2
add action=return chain=client-lb comment=”akhir dari loadbalancing”

/ip firewall mangle
add action=mark-connection chain=lb-proxy dst-address-type=!local new-connection-mark=con-from-isp1 passthrough=yes per-connection-classifier=both-addresses:3/0 comment=”awal load balancing proxy”
add action=mark-connection chain=lb-proxy dst-address-type=!local new-connection-mark=con-from-isp1 passthrough=yes per-connection-classifier=both-addresses:3/1
add action=mark-connection chain=lb-proxy dst-address-type=!local new-connection-mark=con-from-isp2 passthrough=yes per-connection-classifier=both-addresses:3/2
add action=return chain=lb-proxy comment=”akhir dari loadbalancing”

Untuk contoh diatas, pada loadbalancing client dan webproxy menggunakan parameter pemisahan trafik pcc yang sama, yaitu both-address, sehingga router akan mengingat-ingat berdasarkan src-address dan dst-address dari sebuah koneksi. Karena trafik ISP kita yang berbeda (512kbps dan 256kbps), kita membagi beban trafiknya menjadi 3 bagian. 2 bagian pertama akan melewati gateway ISP1, dan 1 bagian terakhir akan melewati gateway ISP2. Jika masing-masing trafik dari client dan proxy sudah ditandai, langkah berikutnya kita tinggal membuat mangle mark-route yang akan digunakan dalam proses routing nantinya

/ip firewall mangle
add action=jump chain=prerouting comment=”marking route client” connection-mark=!no-mark in-interface=wlan2 jump-target=route-client
add action=mark-routing chain=route-client connection-mark=to-isp1 new-routing-mark=route-to-isp1 passthrough=no
add action=mark-routing chain=route-client connection-mark=to-isp2 new-routing-mark=route-to-isp2 passthrough=no
add action=mark-routing chain=route-client connection-mark=con-from-isp1 new-routing-mark=route-to-isp1 passthrough=no
add action=mark-routing chain=route-client connection-mark=con-from-isp2 new-routing-mark=route-to-isp2 passthrough=no
add action=return chain=route-client disabled=no

/ip firewall mangle
add action=mark-routing chain=output comment=”marking route proxy” connection-mark=con-from-isp1 new-routing-mark=route-to-isp1 out-interface=!wlan2 passthrough=no
add action=mark-routing chain=output connection-mark=con-from-isp2 new-routing-mark=route-to-isp2 out-interface=!wlan2 passthrough=no

Pengaturan Routing

Pengaturan mangle diatas tidak akan berguna jika anda belum membuat routing berdasar mark-route yang sudah kita buat. Disini kita juga akan membuat routing backup, sehingga apabila sebuah gateway terputus, maka semua koneksi akan melewati gateway yang masing terhubung

/ip route
add check-gateway=ping dst-address=0.0.0.0/0 gateway=192.168.101.1 routing-mark=route-to-isp1 distance=1
add check-gateway=ping dst-address=0.0.0.0/0 gateway=192.168.102.1 routing-mark=route-to-isp1 distance=2
add check-gateway=ping dst-address=0.0.0.0/0 gateway=192.168.102.1 routing-mark=route-to-isp2 distance=1
add check-gateway=ping dst-address=0.0.0.0/0 gateway=192.168.101.1 routing-mark=route-to-isp2 distance=2

Pengujian

Dari hasil pengujian kami, didapatkan sebagai berikut

 

Dari gambar terlihat, bahwa hanya dengan melakukan 1 file download (1 koneksi), kita hanya mendapatkan speed 56kBps (448kbps) karena pada saat itu melewati gateway ISP1, sedangkan jika kita mendownload file (membuka koneksi baru) lagi pada web lain, akan mendapatkan 30kBps (240kbps). Dari pengujian ini terlihat dapat disimpulkan bahwa

512kbps + 256kbps ≠ 768kbps

Catatan :

* Loadbalancing menggunakan teknik pcc ini akan berjalan efektif dan mendekati seimbang jika semakin banyak koneksi (dari client) yang terjadi.

* Gunakan ISP yang memiliki bandwith FIX bukan Share untuk mendapatkan hasil yang lebih optimal.

* Load Balance menggunakan PCC ini bukan selamanya dan sepenuhnya sebuah solusi yang pasti berhasil baik di semua jenis network, karena proses penyeimbangan dari traffic adalah berdasarkan logika probabilitas.

 

By: Pujo Dewobroto (Mikrotik.co.id)

Openfire on Ubuntu 10.04 Lts

follow the installation in http://www.igniterealtime.org/builds/openfire/docs/latest/documentation/install-guide.html#config

The first problem is Debian package has a dependency on the older “Sun” JRE packages (either sun-java5-jre or sun-java6-jre), which in ubuntu replaced by the OpenJDK packages. Assuming you’ve already installed the OpenJDK package(s), you can work around this dependency by telling dpkg to ignore dependencies:

dpkg -i --force-depends openfire_3.6.4_all.deb

and the next problem came.. the openfire wont start

so u have to edit /etc/init.d/openfire and follow this script

# Attempt to locate JAVA_HOME, code borrowed from jabref package
if [ -z $JAVA_HOME ]
then
    t=/usr/lib/jvm/java-6-openjdk && test -d $t && JAVA_HOME=$t
fi
and you should be able to start
sudo /etc/init.d/openfire start

 

Limit IDM dengan Mikrotik

sumber dari http://www.zulfanruri.com/salah-satu-trik-mengatasi-idm-dengan-mikrotik.htm

Kita asumsikan mikrotik sudah diset dengan benar (Internet Sharing) dan berfungsi dengan baik, dengan blok IP Client yang digunakan adalah 192.168.10.0/24.

Tutorial ini sangat bermanfaat bagi RT/RW net ataupun warnet yang ingin melakukan limitasi untuk akses ke ekstensi file2 tertentu, yang biasanya identik dengan hal download mendownload. Biasanya, si client menggunakan salah satu program yang sudah tidak asing lagi, yaitu IDM.

Dengan menambahkan setingan berikut, hanya aktifitas download saja yang akan kita limit, sehingga aktifitas browsing client tetap lancar.

Langkah-langkahnya adalah sebagai berikut :

1. Masukkan rule di firewall untuk mendapatkan IP server tempat file yang didownload dan memasukan IP itu ke dalam address list.

/ip firewall filter add chain=forward
src-address=192.168.10.0/24 protocol=tcp content=.mp3
action=add-dst-to-address-list address-list=downloads
address-list-timeout=00:05:00
/ip firewall filter add chain=forward
src-address=192.168.10.0/24 protocol=tcp content=.exe
action=add-dst-to-address-list address-list=downloads
address-list-timeout=00:05:00
/ip firewall filter add chain=forward
src-address=192.168.10.0/24 protocol=tcp content=.rar
action=add-dst-to-address-list address-list=downloads
address-list-timeout=00:05:00
/ip firewall filter add chain=forward
src-address=192.168.10.0/24 protocol=tcp content=.zip
action=add-dst-to-address-list address-list=downloads
address-list-timeout=00:05:00
/ip firewall filter add chain=forward
src-address=192.168.10.0/24 protocol=tcp content=.7z
action=add-dst-to-address-list address-list=downloads
address-list-timeout=00:05:00
/ip firewall filter add chain=forward
src-address=192.168.10.0/24 protocol=tcp content=.cab
action=add-dst-to-address-list address-list=downloads
address-list-timeout=00:05:00
/ip firewall filter add chain=forward
src-address=192.168.10.0/24 protocol=tcp content=.asf
action=add-dst-to-address-list address-list=downloads
address-list-timeout=00:05:00
/ip firewall filter add chain=forward
src-address=192.168.10.0/24 protocol=tcp content=.mov
action=add-dst-to-address-list address-list=downloads
address-list-timeout=00:05:00
/ip firewall filter add chain=forward
src-address=192.168.10.0/24 protocol=tcp content=.wmv
action=add-dst-to-address-list address-list=downloads
address-list-timeout=00:05:00
/ip firewall filter add chain=forward
src-address=192.168.10.0/24 protocol=tcp content=.mpg
action=add-dst-to-address-list address-list=downloads
address-list-timeout=00:05:00
/ip firewall filter add chain=forward
src-address=192.168.10.0/24 protocol=tcp content=.mpeg
action=add-dst-to-address-list address-list=downloads
address-list-timeout=00:05:00
/ip firewall filter add chain=forward
src-address=192.168.10.0/24 protocol=tcp content=.mkv
action=add-dst-to-address-list address-list=downloads
address-list-timeout=00:05:00
/ip firewall filter add chain=forward
src-address=192.168.10.0/24 protocol=tcp content=.avi
action=add-dst-to-address-list address-list=downloads
address-list-timeout=00:05:00
/ip firewall filter add chain=forward
src-address=192.168.10.0/24 protocol=tcp content=.flv
action=add-dst-to-address-list address-list=downloads
address-list-timeout=00:05:00
/ip firewall filter add chain=forward
src-address=192.168.10.0/24 protocol=tcp content=.pdf
action=add-dst-to-address-list address-list=downloads
address-list-timeout=00:05:00
/ip firewall filter add chain=forward
src-address=192.168.10.0/24 protocol=tcp content=.wav
action=add-dst-to-address-list address-list=downloads
address-list-timeout=00:05:00
/ip firewall filter add chain=forward
src-address=192.168.10.0/24 protocol=tcp content=.rm
action=add-dst-to-address-list address-list=downloads
address-list-timeout=00:05:00
/ip firewall filter add chain=forward
src-address=192.168.10.0/24 protocol=tcp content=.mp4
action=add-dst-to-address-list address-list=downloads
address-list-timeout=00:05:00
/ip firewall filter add chain=forward
src-address=192.168.10.0/24 protocol=tcp content=.ram
action=add-dst-to-address-list address-list=downloads
address-list-timeout=00:05:00
/ip firewall filter add chain=forward
src-address=192.168.10.0/24 protocol=tcp content=.rmvb
action=add-dst-to-address-list address-list=downloads
address-list-timeout=00:05:00
/ip firewall filter add chain=forward
src-address=192.168.10.0/24 protocol=tcp content=.dat
action=add-dst-to-address-list address-list=downloads
address-list-timeout=00:05:00
/ip firewall filter add chain=forward
src-address=192.168.10.0/24 protocol=tcp content=.daa
action=add-dst-to-address-list address-list=downloads
address-list-timeout=00:05:00
/ip firewall filter add chain=forward
src-address=192.168.10.0/24 protocol=tcp content=.iso
action=add-dst-to-address-list address-list=downloads
address-list-timeout=00:05:00
/ip firewall filter add chain=forward
src-address=192.168.10.0/24 protocol=tcp content=.nrg
action=add-dst-to-address-list address-list=downloads
address-list-timeout=00:05:00
/ip firewall filter add chain=forward
src-address=192.168.10.0/24 protocol=tcp content=.bin
action=add-dst-to-address-list address-list=downloads
address-list-timeout=00:05:00
/ip firewall filter add chain=forward
src-address=192.168.10.0/24 protocol=tcp content=.vcd
action=add-dst-to-address-list address-list=downloads
address-list-timeout=00:05:00
/ip firewall filter add chain=forward
src-address=192.168.10.0/24 protocol=tcp content=.mp2
action=add-dst-to-address-list address-list=downloads
address-list-timeout=00:05:00
/ip firewall filter add chain=forward
src-address=192.168.10.0/24 protocol=tcp content=.3gp
action=add-dst-to-address-list address-list=downloads
address-list-timeout=00:05:00
/ip firewall filter add chain=forward
src-address=192.168.10.0/24 protocol=tcp content=.mpe
action=add-dst-to-address-list address-list=downloads
address-list-timeout=00:05:00
/ip firewall filter add chain=forward
src-address=192.168.10.0/24 protocol=tcp content=.qt
action=add-dst-to-address-list address-list=downloads
address-list-timeout=00:05:00
/ip firewall filter add chain=forward
src-address=192.168.10.0/24 protocol=tcp content=.raw
action=add-dst-to-address-list address-list=downloads
address-list-timeout=00:05:00
/ip firewall filter add chain=forward
src-address=192.168.10.0/24 protocol=tcp content=.wma
action=add-dst-to-address-list address-list=downloads
address-list-timeout=00:05:00
/ip firewall filter add chain=forward
src-address=192.168.10.0/24 protocol=tcp content=.ogg
action=add-dst-to-address-list address-list=downloads
address-list-timeout=00:05:00
/ip firewall filter add chain=forward
src-address=192.168.10.0/24 protocol=tcp content=.doc
action=add-dst-to-address-list address-list=downloads
address-list-timeout=00:05:00

Rule diatas akan menangkap semua traffic dengan ekstensi tertentu dan memasukkannya ke address list downloads selamat 5 menit. Jika ingin menambahkan ekstensi lainnya tinggal dikopas saja.

2. Setting mangle untuk paket yang berasal dari IP yang didapat dari langkah 1.

/ip firewall mangle add chain=forward
protocol=tcp src-address-list=downloads
action=mark-packet new-packet-mark=downloads-paket

3. Langkah terakhir kita masukkan simple queue dari paket mark yang dibuat dari langkah 2.

/queue simple add name=downloads-files
max-limit=128000/128000 packet-marks=downloads-paket

Letakkan queue ini di urutan paling atas, supaya dibaca pertama kali oleh mikrotik sebelum queue lainnya.